Small Business Susan

SBS premium and Quad Core

SBS Premium with ISA Server 2004 on Quad Core CPUs


I hope Darren doesn’t mind me stealing his entire REALLY good blog post about how he got stuck installing Windows 2003 sp2 and ISA on a quad core CPU server and how he needed to get up to ISA 2004 sp2 or sp3 to fix this 

Recently a customer of mine purchased a Dual Quad Core server to act as their SBS Premium server.  They planned to run SQL Server and ISA Server on this machine, and wanted the machine to last 5 to 7 years, so a dual Quad core configuration isn’t out of line, and price wise, it wasn’t much more expensive than two dual core processors.

When they went to install the ISA Server component however, they found that ISA Server wouldn’t start.  Complaining about there being too many processors. 

SBS supports two PHYSICAL CPUs as counted by the number of CPU Sockets on the main board, not by the number of processor cores reported to the operating system.  So ISA not working isn’t a licensing issue, but rather a bug in ISA’s detection of the number of CPUs.

Fortunately, there is a fix: Install ISA Server 2004 SP2.  <edit now install ISA 2004 sp3 instead — Download details: ISA Server 2004 Standard Edition Service Pack 3:
http://www.microsoft.com/downloads/details.aspx?FamilyId=A05A074A-5033-4792-AF8B-58B90D841436&displaylang=en>

To figure out the fastest / least error prone way of doing this, I contacted Microsoft’s Pre-Sales Tech support, and here’s the exact order in which they recommend doing the installation:

Now, there are few different things you need to do before going ahead with installing SP2 on ISA 2004.
1.) Make sure you download SP2 for ISA 2004 and two following roll outs first:

2.) Go ahead and install everything in the following order; SP2, KB 916106 then KB 917902. <instead install ISA 2004 sp3>

Once that is done with, you’ll probably want to install SP2 for Windows, apparently this is a potential problem with ISA; please view the following blog posting for information on the issue, before actually going ahead and installing it.

VPN, SecureNat/Nat and Outlook clients not working after installing Windows Service Pack 2 in SBS 2003 Premium

http://blogs.technet.com/sbs/archive/2007/03/19/vpn-securenat-nat-and-outlook-clients-not-working-after-installing-windows-service-pack-2-in-sbs-2003-premium.aspx

After all that is done, there is a chance that you might experience a performance issue with the workload spiking on one of the CPUs, the support team hasn’t had any calls on it, but just in case, here’s the KB on how to fix it.

Throughput for an ISA Server that is running on a Windows Server 2003 Service Pack 2 (SP2)-based multiprocessor computer may be greatly reduced or completely blocked

http://support.microsoft.com/kb/934809
Darren’s Space: SBS Premium with ISA Server 2004 on Quad Core CPUs:
http://darrenmyher.spaces.live.com/blog/cns!1ABA4CA6583AB317!155.entry



1 comment so far ↓

  • #   Steven Plumlee on 03.16.08 at 4:19 pm     

    We have installed 3 Dell Power Edge 1900′s running dual quad core processors over the last three weeks and have had numerous problems with ISA on all of them. I will have to revisit now since we experienced significant problems with both the Outlook connectivity issue AND with the local network dropping out completely from time to time on on of the clients. Hopefully the articles above will help resolve the issues! – Steve