Exchange System Manager Public Folder Errors

I was working on a customer’s Exchange server today when I got presented with a weird error in Exchange System Manager (ESM) while trying ot do some work on their public folder hierarchy. I was first getting this error:

—————————
Exchange System Manager
—————————

The operation failed because of an HTTP error 501 (Not implemented). Verify that the ExAdmin virtual root exists on the destination server.

ID no: c1030af7
Exchange System Manager

—————————
OK
—————————

I traced this down to someone having applied IP address level restrictions to the various Exchange virtual directories (including exadmin and public) which prohibited me from connecting with ESM to work on the public folder hierarchy. I removed these and then I got a new error:

—————————
Exchange System Manager
—————————

The operation failed due to an invalid format in the HTTP request. Verify that the host header is correct for the virtual server.

ID no: c1030af0
Exchange System Manager

—————————
OK
—————————

I figured out that the Default Web Site which had all the Exchange virtual directories in it was bound to a specific IP address on this server (which had multiple IPs) and that was not the address that ESM was attempting to connect to. Changing this to all unassigned took care of the issue.

After the fact I found this useful link on other errors ESM might throw while managing public folders: http://www.microsoft.com/technet/prodtechnol/exchange/2003/insider/publicfolders.mspx

Share this post: email it! | digg it! | bookmark it! | live it!

Leave a Reply

Your email address will not be published. Required fields are marked *


*

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>