VS2008 Beta 2 strange behavior..

After getting hold of Microsoft Secure Content Downloader CTP i downloaded Visual Studio 2008 Beta 2 Team System and started installing it yesterday.

It got interrupted twice, first by Trend and later by a Windows Update that decided it needed to restart Vista..bummer..

Anyways, finally got it installed and wanted to have a play, but when i clicked on the program link i got a strange error:

This application has failed to start because MSVCR90.dll was not found. Re-installing the application may fix this problem.

Ok, so i tried to re-install..same result when i attempted to run it.

vs2008 error

As you can see, devenv.exe is the file it attempts to execute:

“D:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\devenv.exe”i

Three times and it still displayed this error. Odd..anyways, out of curiosity i tried to just locate the devenv.exe file and run it straight from explorer..and voila, it works…

how the shortcut directly to the executable doesn’t work, but going directly via explorer is beyond me. So now i have a “devenv.exe” shortcut sitting in my quick launch.


So if you get this same error you now know how to overcome it….odd!?!?

  2 comments for “VS2008 Beta 2 strange behavior..

  1. August 4, 2007 at 22:43

    Damn, great minds think alike b/c I’m in the same boat. If I come across a fix, you’re the first one I’ll ping.

  2. August 5, 2007 at 19:20

    Hey Bill!!! good to see you’re still alive and kicking!

    only way i got “around” it was as i said to go directly to devenv.exe – then it runs just fine. The shortcut which the installer puts in there points to the right place/file, yet it throws a hissy when i run it via that.

    rather odd seeing as the executable is the same…

    if you come across a solution (other than my hack) let me know..cheers

Comments are closed.