VS 2010 not installing .NET Framework 2.0 / 3.0 / 3.5 by default

More than a year ago I wrote a popular post:

.NET Frameworks, CLRs and Visual Studio add-ins
http://blogs.msmvps.com/carlosq/2008/11/14/net-frameworks-clrs-and-visual-studio-add-ins.aspx

I stated that VS 2010 would install .NET Framework 2.0, 3.0 and 3.5 (all of them based on CLR 2.0) and, of course, .NET Framework 4.0 (based on CLR 4.0). You may have noticed in the betas of VS 2010 that .NET Framework 2.0, 3.0 and 3.5 are not installed by default, you have to download and install them separately for VS 2010 to use them in projects. So, I have updated the post.

BTW, in the December 2009 issue of MSDN Magazine there is a good article about loading multiple CLRs in the same process

In-Process Side-by-Side
http://msdn.microsoft.com/en-us/magazine/ee819091.aspx