Installing Xcode 4.5 – Fixing "To update this application, sign in to the account you used to purchase it"

XCode 4.5 Released, but I can’t download it!


The big news is that the final version of Xcode 4.5 was released today!


So, I went to the Mac App Store, but when I tried to select “Update” to get the new version, I received the message “To update this application, sign in to the account you used to purchase it”.


Well, I have two accounts (one for the App store and one of the iBookstore), but both accounts gave me the same error message.


The Solution


I uninstalled the beta version of Xcode 4.5. These days it’s as simple as this:


  1. Go to the Applications folder on my Mac
  2. Right-click (or Control+Click) the Xcode.app file and select Move to Trash
  3. I shut down the App Store application, then restarted it


So, when I went back to the App Store, it didn’t detect an existing version of Xcode on my computer, so the button now said Install, and I am officially good to go!


Kevin McNeish
Author of “iOS App Development for Non-Programmers” 
Twitter: @kjmcneish 

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>