Support >> Create Custom Group in your WebPart

Support Email :

Hi Abed,

Sorry for replying late,for any future questions please post it on our DotNetBoom forums.

The Answer : To group your properties in WebPart Development,tag your property with this attribute :

[Category("Custom Properties")]

when you deloy your webpart you will find a Group “Custom Properties” and you will find your properties under it.

By Default,This property if doesn’t set,your property will be shown under “Miscellaneous” group.

Hope This helps.
Feel free to contact me any time.

Regards,
Moustafa Arafa El-Zoughby
DotNet Boom Supportive Development Manager
Website: http://www.dotnetboom.net
Blog: http://moustafa-arafa.blogspot.com
——– Original Message ——–Subject: Question about EditorPart GroupingFrom: “Abdolreza Zanganeh” <zanganeh@gmail.com>Date: Tue, May 20, 2008 1:37 pmTo: moustafa@dotnetboom.netCc: “Paul Beck” <paul.beck@radimaging.co.uk>
Hi Moustafa,
I have a question on development of our webpart. I am developing new webpart and we are using EditorPart. When the user is in “Edit mode”, on right hand side he see the editpart and application configuration. I want to group the webpart properties that shown as textbox grouped with our editorpart not like now separately. I want to know how can I don this.
Thanks for your attention,Rez Zanganeh– RADIMAGING Technical LeaderAbdolreza Zangeneh

VS.Net WSS 3.0 Extensions V1.1

Hi,

Great News,New version of VS.Net 2005 Extensions for WSS 3.0 V1.1 has been released,New templates and tools has been added and updated from the last version V1.0.

Download it now :
http://www.microsoft.com/downloads/details.aspx?familyid=3E1DCCCD-1CCA-433A-BB4D-97B96BF7AB63&displaylang=en

User Guide,to get started with VS.Net 2005 Extensions for WSS 3.0:
http://www.microsoft.com/downloads/details.aspx?FamilyID=A8A4E775-074D-4451-BE39-459921F79787&displaylang=en

The only hope i wish from Microsoft ,i want to see those extensions on Orcas ?!.




Regards,
Mostafa arafa

SharePoint Developers’ Tips for better machine performance

Hi Folks,

As a SharePoint developer or any developer who have SharePoint on your development machine, after a while of developing SharePoint sites you will find that your machine is getting slower and slower and your don’t know plus the space is eating without a clear reason.

The fast action I did, I Deleted all created sites which I don’t use or I don’t want to work on them later, I have deleted all sites with their DBs.
This a good action and bring back my machine to the regular performance J.

This is not enough, for any future work you have to take care of the following:

1) SharePoint is creating a lot of Logs in the following path :
C:\Program Files\Common Files\Microsoft Shared\web server extensions\12\LOGS
Delete the old file to gain more space.
2) Backup SharePoint DBs to cut down the log files of SharePoint databases or shrink log file size.
http://support.microsoft.com/kb/873235


Hope this helps……

Deploy your Windows App using ClickOnce on Vista Machines

Dear Folks,

If you tried to deploy you are windows application using ClickOnce in Visual Studio 2005/2008 on Vista Machine, you will find that your published installation package will not work for clients have Vista machine, Why ? The reason is simple because you as Developer didn’t include Windows Installer 3.1 on your package which is required to run your application on Vista Machine.

The same installation will work for other clients who doesn’t have Vista Machine.

Tip : Windows Installer 3.1 is included on ClickOnce Deployment Package by default if you are running Orcas on Vista Machine J.

Happy .Netting…………..

Regards,
Mostafa arafa

Workflow Settings Link is not showing ??!!

Hi Folks,

I got a request from a friend,that when he tried to configre a list in a sharepoint site,the workflow settings link is not appearing/showing at all although the sharepoint site is a collabotation site, i went and checked the site and i discovered the following :

I went to the site administration -> Site Collection Features -> “Office SharePoint Server Enterprise Site Collection features” feature and it is disabled :) , simply enable it and you will find the workflow setting link will be there on your list settings.

Hope this help.

Regards,
Mostafa arafa