Asp.Net Script manager error with AjaxToolkit

Hi All,

I had an asp.net web application and after i installed the latest AJAX Toolkit from codeplex with build Beta (0911), i was getting this error:

throw new Error(“AjaxControlToolkit requires ASP.NET Ajax 4.0 scripts. Ensure the correct version of the scripts are referenced. If you are using an ASP.NET ScriptManager, switch to the AjaxScriptManager in System.Web.Ajax.dll, or use the ToolkitScriptManager in AjaxControlToolkit.dll.”);

The problem because my script manager in the pages are refering to the asp.net script manager and not the toolkit script manager.

Fix:

Delete all script managers you have and drag and drop a control named “ToolkitScriptManager” in your master pages or pages which script manager resides.

Hope it helps.

Regards,
Mostafa arafa

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>