The Lenovo gets Windows 8.1.. briefly..

Published on: Author: Mike Hall Leave a comment

The machine is a two year old Lenovo G780, the largest laptop made by Lenovo, and is part of the ‘General use’ range. Ours is an i3 and was bought for $500. There are higher spec Lenovo G780’s sporting i5 and i7 Intel processors. The original 4gb RAM was upgraded to 8gb last year. It performs well generally.

I took out the hard drive containing the original OEM Windows 7 installation because this upgrade was a test. The regular user is typical of the breed, never any time to make small adjustments, never makes backups, doesn’t like change, and in this case is adamant that the previous Toshiba laptop was a faster machine even though it actually isn’t.

Installing Windows 8.1..

Having readied a 320gb hard drive, new format, I installed it into the Lenovo. A Windows 8.1 disk was created and I was ready to go.

The first issue was that Windows 8.1 did not like the MBR on the drive that I had had formatted on a non-EFI machine, and wanted to start over with GPT. My machine knows nothing about EFI, but no problem. A restart saw the Windows 8 logo appear, and after adding the key code, it took just 15 minutes to get to the Windows 8 Start screen. So much for it being a slow computer.

Contrary to what I had seen in a forum post, Windows 8 had no problem finding and working with the Broadcom wireless adapter, and the only device that didn’t set up too well was the card reader.

Next, install Start8 trial, and get down to the business of updating Windows and the hardware devices. Windows updates didn’t take long at all, and I had compiled a list of driver from the Lenovo website. You have to look in the driver list for Windows 8 and 8.1 to get the full complement of drivers.Guess what? It all works, and well too. From a technical point, it was all win – win as far as the machine was concerned.

The regular user did not see it the same way. I was informed that everything looked different and nothing was the same to set up even though it was Windows 7 versions that were installed.  The original OEM Windows 7 drive took less than two minutes to re-instate, and all is quiet again.

Conclusion:

I found out what I wanted to know and am perfectly happy with the results.   

Smile

Leave a Reply