Search

June 2005
M T W T F S S
« May   Jul »
 12345
6789101112
13141516171819
20212223242526
27282930  

Parent Portal’s Virtual Server was deleted in IIS. How to recover?

June 26th, 2005 by


From: <Lisa@discussions.microsoft.com>


Subject: Parent Portal’s Virtual Server was deleted in IIS.  How to recover


Date: Mon, 20 Jun 2005 06:56:31 -0700


Newsgroups: microsoft.public.sharepoint.portalserver


 


My sharepoint server is running in a shared service environment.  The virtual server that my parent portal was extended from has been deleted from IIS.  How can I salvage this situation?  Unfortunatly I can’t restore from the MeteBase.  What would happen if I delete this parent portal that no longer worked and created a new one?


 


*************************************


 


From: “Shane Young”


Subject: Re: Parent Portal’s Virtual Server was deleted in IIS.  How to recover


Date: Mon, 20 Jun 2005 10:49:59 -0400


Newsgroups: microsoft.public.sharepoint.portalserver


 


If you delete the parent portal and create a new one on the same farm it should automatically become the new parent.  As you probably have noticed without the parent running your child portals are not happy.  A child can not be promoted to a parent but a new portal you create should become the new parent.  If you backup the parent DB’s you may be able to restore them once you create the new portal.


 



Shane Young


http://www.lucruminc.com


 


I will be presenting at SharePoint Advisor Live!


Stop by and say hello.  I will also be at the http://www.SharePointSolutions.com  booth


 


*************************************


 


From: <Lisa@discussions.microsoft.com>


Subject: Re: Parent Portal’s Virtual Server was deleted in IIS.  How to rec


Date: Mon, 20 Jun 2005 15:33:01 -0700


Newsgroups: microsoft.public.sharepoint.portalserver


 


Shane,


 


Thanks for the post.  I tried deleting the parent portal, but received the following error:


15:28:02 An exception occurred.


System.Configuration.Install.InstallException: Portal virtual server is not extended on this machine.(1a04ba93-3619-416f-99ef-1fd74ac3d316) at Microsoft.SharePoint.Portal.Install.c.d(IDictionary A_0) at


Microsoft.SharePoint.Portal.Admin.b.a()


15:28:02 Portal deletion finished. Status


 


How can I get around this.  My IIS site was deleted from IIS and I couldn’t restore from the MetaBase.


 


Thanks


 


*************************************


 


From: “Shane Young”


Subject: Re: Parent Portal’s Virtual Server was deleted in IIS.  How to rec


Date: Mon, 20 Jun 2005 19:09:54 -0400


Newsgroups: microsoft.public.sharepoint.portalserver


 


What happens if you create a new portal?  Just ignore the old one for the time being and try creating a total separate new portal.


 



Shane Young


http://www.lucruminc.com


 


*************************************


 


From: <Lisa@discussions.microsoft.com>


Subject: Re: Parent Portal’s Virtual Server was deleted in IIS.  How to rec


Date: Mon, 20 Jun 2005 16:41:02 -0700


Newsgroups: microsoft.public.sharepoint.portalserver


 


When I create a new portal, it says it’s a child of the parent portal (even though it’s not extended on a virtual machine anymore)


 


*************************************


 


Subject: Re: Parent Portal’s Virtual Server was deleted in IIS.  How to rec


Date: Mon, 20 Jun 2005 23:49:51 -0400


Newsgroups: microsoft.public.sharepoint.portalserver


 


Yuck!  I am not exactly what to tell you then.  Have you tried recreating the parent IIS site and then extending it again and then deleting it?  I am at that point where I would just be guessing so not sure how much I would help.  Sorry.


 



Shane Young


http://www.lucruminc.com


 


*************************************


 


From: <Lisa@discussions.microsoft.com>


Subject: Re: Parent Portal’s Virtual Server was deleted in IIS.  How to rec


Date: Tue, 21 Jun 2005 11:20:02 -0700


Newsgroups: microsoft.public.sharepoint.portalserver


 


That worked!  I created the IIS site as best as I could and extened it.


 Then I could delete the parent portal (but I didn’t delete the databases).  Afterwards I couldn’t create a new portal site, but I could restore the delete parent portal.  And now it works just like it use to.


 


Thanks for all your help.



 

Posted in SPPS03_Tips | No Comments »



Comments are closed.