Search

March 2007
M T W T F S S
« Feb   Apr »
 1234
567891011
12131415161718
19202122232425
262728293031  

Templates don’t save Toolbar Type or view

March 27th, 2007 by

From: “super1”
Subject: Templates don’t save Toolbar Type or view
Date: Mon, 26 Mar 2007 08:34:54 -0700
Newsgroups: microsoft.public.sharepoint.portalserver

I created a sub site, added several parts to the main page and saved it as a template.  The template does not save the toolbar type (I prefer none) nor does it save the view the web parts are using.  The view is there, it just isn’t being used to display the information.

Is this normal?  Is this disappointing to anyone else?

MOSS 2007

**************************************

From: v-adapanatonlinedotmicrosofttodcom (“Ada Pan [MSFT]”)
Date: Tue, 27 Mar 2007 07:04:06 GMT
Subject: RE: Templates don’t save Toolbar Type or view
Newsgroups: microsoft.public.sharepoint.portalserver

Hello Super,

According to your description, the issue you encountered is a defect of WSS 3.0. The Changes that we make to the “List View” Web Part are not retained after we save the site as a template in WSS 3.0 and MOSS 2007. For more detail about this issue, you can follow the link:

Changes that you make to the “List View” Web Part are not retained after you save the site as a template in Windows SharePoint Services 3.0

http://support.microsoft.com/kb/926284S

However, Microsoft has made a hot fix to resolve this issue. To see the details about this hot fix, please go to

http://support.microsoft.com/kb/931636.

You need to request the hot fix from our Product Service Support Center to get that hot fix.

Hope this could help you.  If you have any question, please feel free to post back.

Regards,

Ada Pan  

Microsoft Online Partner Support
Get Secure! –
www.microsoft.com/security
=======================================
When responding to posts, please “Reply to Group” via your newsreader so
that others may learn and benefit from your issue.
=======================================
This posting is provided “AS IS” with no warranties, and confers no rights.

**************************************

From: “super1”
Subject: Re: Templates don’t save Toolbar Type or view
Date: Thu, 29 Mar 2007 09:05:26 -0700
Newsgroups: microsoft.public.sharepoint.portalserver

Thanks for letting me know about the hotfix.  This should help. Do you know of any problems with applying it?  Of course I will try it on a  test system, but you don’t always know what to try in a short test.

Thanks again.

**************************************

From: Ada Pan [MSFT]
Date: Fri, 30 Mar 2007 09:35:48 GMT
Subject: Re: Templates don’t save Toolbar Type or view
Newsgroups: microsoft.public.sharepoint.portalserver

Hello Super,

After you apply the hotfix KB931636, you can fix the following issues:

926284 Changes that you make to the “List View” Web Part are not retained after you save the site as a template in Windows SharePoint Services 3.0 

931008 You cannot perform a search query after you upgrade to Microsoft Windows SharePoint Services 3.0 on a Microsoft Windows Small Business Server 2003-based computer 

932055 You cannot select the values for a custom field when you try to edit the properties on the FldEditEx.aspx page on a Windows SharePoint Services 3.0 Web site 

932056 One or more custom programs do not finish successfully when you run multiple custom programs that use the BreakRoleInheritance function in the Windows SharePoint Services 3.0 object model 

932347 Windows SharePoint Services 3.0 does not comply with daylight saving time in Western Australia for the years 2006 to 2009 

Also after you apply this hotfix package, you must run the SharePoint Products and Technologies Configuration Wizard.  To do this, click Start, point to All Programs, point to Administrative Tools, and then click SharePoint Products and Technologies Configuration Wizard.

I don’t see any problem described in the KB article.  However, it is always recommended to apply the hotfix in a test environment and then deploy to the productive environment.

If you have any questions, please let me know.

Regards,

Ada Pan  

Microsoft Online Partner Support
Get Secure! –
www.microsoft.com/security
========================================
When responding to posts, please “Reply to Group” via your newsreader so that others may learn and benefit from your issue.
========================================
This posting is provided “AS IS” with no warranties, and confers no rights.

**************************************

From: “super1”
Subject: Re: Templates don’t save Toolbar Type or view
Date: Tue, 3 Apr 2007 09:21:19 -0700
Newsgroups: microsoft.public.sharepoint.portalserver

Now that my restore from backup works, I am more willing to try the patch. I will plan on doing it tomorrow morning.

**************************************

From: “super1”
Subject: Re: Templates don’t save Toolbar Type or view
Date: Thu, 5 Apr 2007 07:37:53 -0700
Newsgroups: microsoft.public.sharepoint.portalserver

The hotfix did help.  Most of what I want to save is now included.  However, the setting of showing the quick launch bar is not saved in the template still.  Oh well, I just emptied the quick launch bar and it has the same effect.

Thanks

**************************************

From: Ada Pan [MSFT]
Date: Fri, 06 Apr 2007 03:27:43 GMT
Subject: Re: Templates don’t save Toolbar Type or view
Newsgroups: microsoft.public.sharepoint.portalserver

Hello Super,

Thank you for your response.

I am glad to know the hotfix is helpful in certain.  Regarding the not retained Quick Launch settings, I have reported to the related team but still wait for the update from them.

Once I get any update, I will post back.  Thank you for your time and patience.

Regards,

Ada Pan  

**************************************

From: Ada Pan [MSFT]
Date: Tue, 10 Apr 2007 07:24:34 GMT
Subject: Re: Templates don’t save Toolbar Type or view
Newsgroups: microsoft.public.sharepoint.portalserver

Hello Super,

Unfortunately, the feedback from the product team is that this issue cannot be resolve at the time being.  For some historic reasons, they are still investigating and try to find a workaround for this issue. 

I totally understand the inconvenience this may bring to you. Hopefully they will figure out a solution/workaround on it soon and make changes to the next Service Park or generation. 

I would also like to invite you to submit a wish for this to our Feedback department. This is another way that let the developers know what you would like to be able to do and/or see added in future versions. You can send to Feedback anytime and send Feedback very easily by going to the following link or click Contact Us on Help menu in Excel:

<http://www.microsoft.com/office/community/en-us/wizard.mspx?type=suggestion&lang=en&cr=US&cat=en-us-office&pt=3a4e9862-cdce-4bdc-8664-91038e3eb1e9>

I will still keep eyes on this issue and keep you updated if there is news from the dev team.

Your understanding is greatly appreciated.

Regards,

Ada Pan  

Microsoft Online Partner Support
Get Secure! –
www.microsoft.com/security

End slug

Posted using BlogJet

Posted in Moss 2007 | No Comments »



Comments are closed.