Reinicios de Windows 8 nada más arrancar

Hace un par de días realicé una nueva instalación de Windows 8 Profesional, en un equipo que ya tenía un Windows 8 Enterprise  que funcionaba correctamente. Lo instalé en un disco duro nuevo, GPT, montado en una placa ASUS UEFI de última generación (ASUS Rampage IV Extreme, con un Core i7 3930K).


La instalación comenzó bien, y al primer reinicio, tras el menú de selección de sistema operativo, en cuanto aparecía la ventana azul el equipo se reiniciaba al instante. El problema añadido es que como el menú de arranque gráfico va iniciando Windows 8 al mismo tiempo, en el proceso se reiniciaba constantemente el equipo sin ni siquiera mostrar el menú de arranque. Un problema, pues no solo fallaba el nuevo sistema operativo, sino que tampoco podía acceder al existente. Ni siquiera apagando el equipo, pues al encenderlo directamente se reiniciaba en cuanto intentaba cargarse el menú de arranque.


A base de probar, una de las veces al arrancar intenté entrar en la BIOS (de tipo UEFI), lo que es un problema ya que con el inicio rápido de Windows 8 ni siquiera se muestra en pantalla la información del arranque inicial del sistema. Cual fue mi sorpresa cuando, al salir de la BIOS, sin ni siquiera guardar, apareció el menú de arranque y pude entrar en mi Windows 8 Enterprise de siempre.


El primer paso para arreglar el desaguisado fue cambiar el modo de menú de arranque gráfico por el menú de arranque en modo texto de toda la vida. Para ello, desde Windows 8 abrimos una ventana de comando con elevación y tecleamos lo siguiente:


bcdedit /set {current} bootmenupolicy Legacy


bcdedit /set {GUID del Windows 8 profesional} bootmenupolicy Legacy


El GUID del Windows 8 profesional lo obtenemos previamente tecleando tan solo bcdedit en la ventana de comando.


Con esto perdemos el menú de arranque gráfico, pero a cambio, el menú de arranque en modo texto no se ve afectado por fallos a la hora de iniciar el sistema operativo. Ya en otra instalación me pasó algo similar, causado en aquel caso por un driver de controladora de disco que impedía el arranque del sistema.


Con esta nueva situación podía arrancar el W8 Enterprise sin problemas, pero al lanzar el W8 profesional el equipo se reiniciaba, aunque al menos volvía al menú de arranque.


Vuelta a lanzar la BIOS durante un reinicio, y al salir y seleccionar que arranque W8 profesional veo que continua arrancando y por fin finaliza la instalación (me costó un par de reinicios entrando y saliendo de la BIOS).


Pensando en que el problema estaría en algún driver o relacionado con aquellas actualizaciones de WU mastodónticas que nos aparecen tras una instalación nueva, aproveché para instalar cuantos drivers disponía actualizados, y le pasé un WU para instalar todas las actualizaciones. El resultado, el problema persistía, y siempre podía arrancar W8 Enterprise pero el Profesional se reiniciaba, salvo que entrase y saliese de la BIOS, en cuyo caso el W8 Profesional arrancaba sin problemas.


Las sospechas comenzaron a centrarse en el inicio rápido de Windows 8 como causante del problema. Una buena novedad para reducir al máximo el tiempo de arranque del sistema, pero que en este caso resultó ser la causa del problema. En primer lugar deshabilité el inicio rápido, desde Panel de Control, Opciones de Energía, Elegir el comportamiento de los botones de Inicio/Apagado. El problema persistía. Deshabilité a continuación la hibernación completamente con el comando “powercfg -h off”. El problema seguía. ¿No era entonces el inicio rápido?


Por enésima vez volví a revisar las opciones de la BIOS UEFI, esta vez con lupa, y encontré una opción llamada Inicio rápido, que lo que hace, si está activada, es inicializar tan solo los dispositivos imprescindibles para el arranque del sistema, dejando que el sistema operativo inicialice el resto durante el arranque. Como estaba activada, la deshabilité, guardé valores y reinicié.


Et voilà, el problema con Windows 8 Profesional ha desaparecido. Ahora, siempre que reinicio o arranco el equipo muestra en pantalla la información de arranque del sistema, y en todo caso cuando selecciono uno u otro sistema operativo éste arranca correctamente. Y la verdad, salvo los cinco o seis segundos en que se muestra la información de arranque citada, no veo que Windows 8 tarde ni más ni menos que antes.


Está claro que la mencionada opción de la BIOS causaba un conflicto con la característica de inicio rápido de Windows 8, pues tan solo deshabilitando ambas logré que el Windows 8 profesional arrancase. Este problema puede ser específico de esta placa e instalación, pero no estará de más tener en cuenta esta solución en otros casos similares, buscando también opciones parecidas que puedan existir en otras placas.


Lo más raro de esto, y a lo que todavía no encuentro explicación, es por qué el Windows 8 Enterprise siempre ha arrancado correctamente, desde el primer día, con hibernación habilitada, inicio rápido (aunque estas dos cosas las deshabilité en su momento) y con el inicio rápido de la BIOS habilitado. Misterios de los bits. No estaría de más seguir investigando, pero ahora mismo prefiero aplicar el principio número uno de la Informática: si funciona no lo toques.

One thought on “Reinicios de Windows 8 nada más arrancar”

  1. Gracias por tu post. A mi me pasaba algo parecido, siempre que iniciaba la pc, se ponía la pantalla “Windows se está iniciando” de Windows 8 y se reiniciaba casi enseguida. Una vez se reiniciaba comenzaba a andar de manera normal: inciaba el grub y podía elegir entre Windows 8 y Manjaro Linux.
    Por suerte di con tu post e hice lo de deshabilitar el inicio rápido y se solucionó el problema.
    Así que gracias

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>