Categories

DSC and WMI

Like all well behaved technology Desired State Configuration (DSC) requires access to WMI. Specifically it needs root/Microsoft/Windows/DesiredStateConfiguration

This is available on the Windows 2012 R2 DSC server you configure but isn’t available on older versions of Windows.

You must install Windows Management Framework 4.0  (PowerShell 4.0) on any machine that you are going to configure through DSC. Windows Server 2012 already has it installed but for Windows 2008 R2 & Windows 2012 you’ll need to download the appropriate version of WMF 4.0 and install it.

Leave a Reply