RequiredRuntime fails for targetting CLR versions

Recently, I walked right into an ambush with .NET. A client asked how best to target a CLR version from a .NET application. Easy right? Just use this in an app.config file: <startup>  <requiredRuntimeversion=”v1.0.3705″ safemode=”true”/></startup> As it turns out, this simply won’t work for any version above 2.0. Bummer! I hate those issues because it makes you look stupid as a consultant. Even worse, it makes the framework looks like it is broken – ofcourse it is. The blame game is an appropriate response, but it doesn’t solve the problem at hand. As it turns out, there is no bullet … Continue reading RequiredRuntime fails for targetting CLR versions