A new hotfix is available that may affect a number of SBS 2003
installations.

The symptoms described below on an SBS 2003 Server running on a system with
2 or more logical processors (this will include CPU’s with hyperthreading
support) are covered by this hotfix.

Symptoms:

You may receive several (1 per minute) Event Id 8331 for MsExchangeAL in the
event viewer.

Event Type:             Error
Event Source:         MSExchangeAL
Event Category:       Address List Synchronization
Event ID: 8331
Date:                       11/20/2003
Time:                       5:06:16 PM
User:                        N/A
Computer:                CONTOSO
Description:

The service threw an unexpected exception which was caught at
f:\titanium\dsa\src\lra\abv_dg\lservagent.cpp(4511)

Note that the source file and line number may differ

Another symptom is that AD updates from Exchange are not working, new users
do not get stamped with Exchange attributes. You may see the symptoms and
have no new events.

——
If you have seen those symptoms, are seeing it or even if you have an SBS
2003 system that has 2 or more logical processors and you are running
Exchange, you can contact PSS and ask for the hotfix found on KB article
837444. The call for a hotfix is a no-charge call. In order to find the
local PSS number for your country, go to
http://support.microsoft.com, the
US number is (800) 936-4900.

The actual KB article is still in works and should be ready soon, but the
hotfix is live right now.

This fix will be included in Exchange 2003 Service Pack 1.

Regards,

Damian

-- Damian N. Leibaschoff, MS IST, MCSE Microsoft Corporation

 

 

8 Responses to Event 8331 – Titanium error – we have a hotfix! [Thanks Damian!]

  1. I WILL ASK THIS PATCH, I SEE THIS ERROR IN ANY SERVER SBS 2003 WITH XEON IN HYPERTREADING BUT I THINK THAT THE ANTIVIRUS COULD GENERATE THE PROBLEMS IF THERE AREN’T ANY DIRECTORY EXCLUSION. I USE INOCULATE IT 7.0 AND I CONFIGURED AN EXCLUSION OF THE C:\PROGRAMS\EXCHSRVR AND THE PROBLEM IS SOLVED. DOES ANYONE CONFIRM THIS SOLUTION?

    YOU CAN ANSWER TO ME AT

    M.BIANCHI@BVM.IT

    THANKS.

  2. NOW THERE IS THE FIX FROM MICROSOFT. ANYONE USED IT?

  3. David Johnson says:

    I applied the Exchange SP1 last night, but still getting the error? Was the hot fix in the service pack?

  4. rag says:

    can you please send me the hotfix?

    Thanks

    ragitm@gmail.com

  5. Marcela says:

    I´m really nedding this hotfix.

    Please, could some generous soul send it to me?

    tks, Marcela.

    marcela.formighier@gmail.com

    marlf50@hotmail.com

  6. David Johnston says:

    Hi Marco,

    I have try excluding C:\Program files\Exchsrvr from the Real-time scanner.

    It did not stop the errors. Running Inoculate 7.1 on SBS2003 Premium.

    Have just received the Hot fix & will try that.

    Dave J

  7. Junior says:

    SP1 of Microsoft Exchange Server 2003 can be easly found under microsoft.com for free download.

    JR

  8. Junior says:

    Article: http://www.kbalertz.com/kb_837444.aspx

    #837444 under Microsoft KB(Knowledge Base).. all link to download SP1 are there.