Attack of the “Technical Beta”!

Beta: Software still in development that has not been completed and not ready for general everyday use.


So, you have installed the Technical Beta of WMP 10 and it’s not working out the way you thorught, what should you do?  Here’s a little list of things to do and what should be going through you head.


#1 – Be calm.  Part of beta testing is getting mad becuase something doesn’t work right.  The thing you need to remember is that it is beta software.  If this software was perfect and 100% working it would not be tagged with the words “beta”.  At this point when it’s done it’s refered to as Final or in some cases Gold.


#2 – Report issues and problems.  The main thing to remember when doing this is not blame an issue on the makers of the software or the people trying to help you.  When posting you will want to include the best information you can about the exact issue you are having.  While doing this you need ti remember what you just read in #1.


#3 – Don’t blame Microsoft.  Remember as you have read this beta software is not really for general use.  There is a chance you will screw up your PC.  the overall truth is if you installed the software without having a backup of your data it is no ones fault but your own.  There was that disclaimer you likely did not read on the WMP 10 beta site, so don’t blame anyone or make stupid remarks about “Microsoft being dumb and screwing up your PC”.  Just in case you did not read that disclaimer here it is.


“This is a technical beta release. Before you decide whether to install this software, it is important to understand that the technical beta release does not have the stability of released Microsoft software. You might encounter problems with this release of the software that could possibly result in a loss or destruction of data. This release is not for production use, and we suggest that you run the software in a test environment or back up your existing data, including music and video files, before you install and run the software on your computer.”


#4 – Understand the final version will fix thing.  It is very important that you understand this.  The whole point of Microsoft doing a “Technical Beta” is to get feedback and find more bugs.  If you like WMP 9 don’t play the “i’ll use MusicMatch now becuase this beta sucks” card,  that’s not cool.  Everyone understands you want if to work, hell so do I and Microsoft.  The WMP team works their butts off to fix things and give you great software.  People like me beta test the releases and submit dozens of bugs.  By installing the “Technical Beta” you join this group.  You are helping, just make sure #3 and really understand at it is not finished and blaming someone is not needed or helpful.


#5 – Last, if you have a problem search the newsgroups first, then post if you find you don’t see any help.  For example if you have problems uninstalling the beta, you will find 15+ threads about it.  Don’t start another one asking how to do, look at the others.  If you have other issues make a post and include all your problems and issues nicely in the thread.

3 thoughts on “Attack of the “Technical Beta”!

  1. Very good points on the beta. Say what you will about Microsoft products and the slow pace of development but you definately can’t bitch about the beta bugs. You signed up for the program and could have stuck with Windows Media Player 9. I have found the WMP technical beta 10 though to be remarkedbly stable.

    This being said, it would be nice, beta 10 or WMP 9 to get the darned thing to load my music faster. With 70,000 + mp3s it takes forreeeever to load — upwards of 5 minutes sometimes. Also sometimes my album artwork doesn’t copy over on rips even after I delete all my temp files, both on 9 and 10. All the music copies over just fine but no artwork. What’s up with that?

    Tom

    Thomas Hawk’s Digital Connection

    http:/thomashawk.com

  2. hey guys/gals keep up the good work…..

    on to business..

    so yah i had mp9 works well….got the new version mp10 not so well…

    can not uninstall.. safe mode, rollback to mp9, restore..

    dont work give you have some more info please post…

Leave a Reply to Chris Lanier Cancel reply

Your email address will not be published. Required fields are marked *