Java Plugin and Web Start Version Specification Security Issue

Affected Software:
Java Web Start 1.x
Sun Java JDK 1.5.x
Sun Java JRE 1.3.x
Sun Java JRE 1.4.x
Sun Java JRE 1.5.x / 5.x


A security issue has been reported in Sun Java Plugin and Sun Java Web Start, which can be exploited by malicious people to bypass certain security restrictions.


The security issue is caused by an error that allows applets and applications to run with a version of the JRE that it is not specified to run with (e.g. that does not have the latest security fixes).


The security issue affects:
* Java Plug-in included with J2SE 5.0 Update 5 and earlier, 1.4.x, 1.3.1, and 1.3.0_02 and later.
* Java Web Start included with J2SE 5.0 Update 5 and earlier, and 1.4.2.
* Java Web Start 1.2, 1.0.2, 1.0.1, and 1.0.


Solution: Updated to a fixed version.


http://secunia.com/advisories/21570/

Leave a Reply