Firefox Password Manager Information Disclosure

Affected Software: 


Mozilla Firefox 1.x
Mozilla Firefox 2.x


Robert Chapin has discovered a vulnerability in Firefox, which can be exploited by malicious people to conduct phishing attacks.


The vulnerability is caused due to the Password Manager not properly checking the URL before automatically filling in saved user credentials into forms. This may be exploited to steal user credentials via malicious forms in the same domain.


The vulnerability is confirmed in version 2.0.0. Other versions may also be affected.


Solution: Disable the “Remember passwords for sites” option in the preferences.


 http://secunia.com/advisories/23046/

Leave a Reply