Multiple PDF Readers Multiple Remote Buffer Overflow Vulnerability

Vulnerable:
Xpdf Xpdf 3.0.1 (Patch 2)
Apple Mac OS X Preview.app 3.0.8
Adobe Acrobat Reader v8 and earlier versions


Multiple PDF readers are prone to multiple remote buffer-overflow vulnerabilities. These issues occur because the applications fail to bounds-check user-supplied data before copying it into an insufficiently sized buffer.


An attacker can exploit these issues to execute arbitrary code within the context of the affected application or crash the affected application, denying service to legitimate users.


http://www.securityfocus.com/bid/21910

Leave a Reply