End of Support: Netscape Browser

After February 1, there will be no more active product support for Navigator 9, or any previous Netscape Navigator browser. This includes Netscape v1-v4.x, Netscape v6, Netscape v7 Suite, Netscape Browser v8, and Netscape Navigator/Messenger 9.

We’ll continue to release security patches for the current version of the browser, Netscape Navigator until February 1, 2008.

http://blog.netscape.com/2007/12/28/end-of-support-for-netscape-web-browsers/

Leave a Reply