Just a small request for comments. Oren prefers if (GetTrueOrFalse() == false) …instead of if (!GetTrueOrFalse()) Coming from 18+ years of C/C++ based language programming, I find either equally readable; but, I’m not always the one reading my code. What are you thoughts? Do you prefer the negation operator (!) or explicitly comparing with the false keyword?